Ergebnis 1 bis 10 von 10

Thema: atmega2560 Flash Nutzung >50%=crash

Baum-Darstellung

Vorheriger Beitrag Vorheriger Beitrag   Nächster Beitrag Nächster Beitrag
  1. #1
    Kabelträger
    Registriert seit
    03.11.2016
    Beiträge
    6

    atmega2560 Flash Nutzung >50%=crash

    Hallo,

    wenn der Flash des atmega2560 über 50% genutzt wird, bleibt er stehn.
    Dachte es wäre mein Programm, jedoch selbst einfaches LED blinken geht dann nicht mehr.

    Edit: Ebenfalls aufgefallen: ich kann nur (hehe "nur") 8191 Bytes der vorhandenen 8192 Bytes SRAM benutzen (dieser Fehler ist beim atmega640 nicht vorhanden, obwohl gleiche SRAM größe).

    Code:
    
    $regfile = "m2560def.dat"
    $crystal = 16000000
    $hwstack = 64
    $swstack = 64
    $framesize = 64
    
    'I/O ##################################################################################################################
    Ddrj = &B1111_1110
    Led1 Alias Portj.2
    Led2 Alias Portj.3
    Led3 Alias Portj.4
    Led4 Alias Portj.5
    Led5 Alias Portj.6
    Led6 Alias Portj.7
    
    'uart #################################################################################################################
    Config Com4 = 57600 , Synchrone = 0 , Parity = None , Stopbits = 1 , Databits = 8 , Clockpol = 0
    Open "com4:" For Binary As #4
    
    Do
    
       Toggle Led1
       Wait 1
    
    Loop
    
    Close#4
    
    End
    
    'data #################################################################################################################
    
    '54% Flash = crash
    '$include "E:\Kevin\Elektronik\Bascom inc\randomdata.bas"
    
    '36% Flash = ok
    $include "E:\Kevin\Elektronik\Bascom inc\randomdatab.bas"
    LG
    Shizz0
    Geändert von Shizz0 (23.12.2016 um 16:42 Uhr)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •